عدم پشتیبانی گوگل پلی از اندروید 2.3 تا 3.2 از اوایل سال2017

پشتیبانی سرویس‌های گوگل‌پلی از اندروید ۲.۳ تا اندروید ۳.۲ در اوایل سال ۲۰۱۷ پایان می‌یابد.



پشتیبانی سرویس‌های گوگل‌پلی از اندروید ۲.۳ تا اندروید ۳.۲ در اوایل سال ۲۰۱۷ پایان می‌یابد.

امروز شرکت گوگل اعلام کرده است که گوگل‌ پلی‌ سرویس ۱۰.۰.۰ و فایربیس ۱۰.۰.۰ در واقع آخرین نسخه‌های این کتابخانه‌ها خواهند بود که از اندروید API 9 تا اندروید API 13 پشتیبانی می‌کنند. حداقل نسخه‌ی اندروید مورد نیاز برای نسخه‌ی بعدی این دو کتابخانه (۱۰.۲.۰) که در اوایل سال ۲۰۱۷ منتشر خواهد شد، API 14 خواهد بود و این یعنی برای استفاده از نسخه جدید گوگل‌ پلی ‌سرویس و فایربیس نیاز به اندروید ۴.۰ دارید. در نتیجه‌ی این اقدام، پشتیبانی از اندروید ۲.۳ نان زنجبیلی و اندروید ۳.۰ و ۳.۱ و ۳.۲ در این کتابخانه‌ها متوقف خواهد شد. در ادامه‌ی مطلب با زومیت همراه باشید.

سرویس‌های گوگل‌ پلی در ماه سپتامبر ۲۰۱۲ معرفی‌ شد و در اصل خدمات پس‌زمینه‌ی گوگل را برای اندروید به ارمغان می‌آورد. با استفاده از کتابخانه‌ی مورد اشاره، گوگل یک‌سری از بروزرسانی‌ها را بدون نیاز به آپدیت کلی سیستم‌عامل اندروید در اختیار کاربران قرار می‌دهد. 

بنا بر جدیدترین آمارهای ارائه‌شده در مورد درصد استفاده از نسخه‌های مختلف سیستم‌عامل موبایلی گوگل، اندروید نان زنجبیلی که اولین بار در دسامبر ۲۰۱۰ منتشر شد، هم‌اکنون فقط بر روی ۱.۳ درصد از کل دستگاه‌های اندرویدی که Google Play Services بر روی آن‌ها نصب است، اجرا می‌شود. به‌ عبارت‌ دیگر تصمیم گوگل مبنی بر عدم پشتیبانی از این نسخه‌ از اندروید در بروزرسانی بعدی کتابخانه‌ی خدمات‌ گوگل‌‌ پلی تعجب چندانی ندارد.

در ادامه بخشی از توضیح تیم اندروید را در مورد اقدام یادشده می‌خوانیم:

پلتفرم نان‌ زنجبیلی ‌اکنون شش سال عمر دارد. بسیاری از توسعه‌دهندگان اندروید از مدت‌ها قبل، پشتیبانی از این نسخه را در اپلیکیشن‌های خود متوقف کرده‌اند. همین موضوع به آن‌ها کمک می‌کند تا بتوانند اپلیکیشن‌های بهتری را تولید کنند و از قابلیت‌های جدید پلتفرم اندروید بهره ببرند. برای ما نیز همین شرایط وجود دارد. با ایجاد این تغییر ما قادر خواهیم بود مجموعه‌ای از ابزارهای قدرتمند‌تر و بهتر را با سرعتی بیشتر برای توسعه‌دهندگان اندروید ارائه کنیم.

به‌منظور روشن‌تر شدن موضوع بد نیست اشاره کنیم که توسعه‌دهندگان می‌توانند همچنان از نسخه‌ی ۱۰.۰.۰ گوگل پلی سرویس و فایربیس به‌منظور پشتیبانی از دستگاه‌هایی که اندروید ۲.۳ تا ۳.۲ را اجرا می‌کنند، بهره ببرندِ؛ اما پس از بروزرسانی به نسخه‌ی ۱۰.۲.۰ یا نسخه‌های جدیدتر ، حداقل نسخه‌ی اندروید مورد نیاز برای اجرای اپلیکیشن‌ها، API level 14 خواهد بود.البته مطمئنا دیر یا زود شاهد توقف کامل استفاده از دو نسخه‌ی قدیمی اندروید ۲.۳ تا ۳.۲ خواهیم بود.


منبع :